Jump to content

Follow us on...
Follow us on Google PlusFollow us on TwitterFollow us on Facebook
The UK's No.1 Chrysler Owners Forum

Photo
- - - - -

Park Assist Issue


  • Please log in to reply
2 replies to this topic

#1 clarkster72

clarkster72

    L Plates

  • Members
  • Pip
  • 4 posts
  • LocationHartlepool

Posted 07 May 2020 - 11:43 AM

Hi Everyone, New to this forum even though had my 300c SRT8 for over 8 years. 

My Rear Park Assist is Dead, no lights or sounds even on initial key turn. Won't toggle on/off in EVIC, just states ON. No warnings on EVIC either. I suspect it could be my Park Assist Module. Anyone had similar issues? Does anyone near me in the North East have a spare Module I could try before buying a new one? Part number is 04602421AF.

 

Any help would be appreciated.  :)  



#2 BrownSugar

BrownSugar

    Just Passed

  • Members
  • PipPip
  • 44 posts
  • LocationStevenage

Posted 10 May 2020 - 12:53 PM

A while ago my reversing sensors were playing up. The lights would come on randomly and it would beep when I was driving forward. On another post Briscoe76 put the below info on. It fixed the problem and also sorted several other electrical gremlins I had... radio playing up, speedo needle randomly waving about, indicators missing a beat, random warning lights. Give it a go, it's the best tip I've read for years.

 

PS: Really envious that you have an SRT8.

 

Briscoe76

 

Hi, did you get this problem sorted at all?

 

If you didn't, then its an easy fix. Open the bonnet and, and find the washer bottle. Next to that, bolted to the drivers side wing, you will find a black box. Unplug the box, and hey presto, the fault will vanish. It will also cure a few other faults, such as indicators that miss a click, rear wipers wiping on their own, reversing sensors firing up when your driving forward.

 

The box is the HID translator module. All it does is let the ECU know when a headlight bulbs blows. If you can live without that function then you can cure all the rest!! The HID module develops a fault, and effects lots of other things down the line.


Edited by BrownSugar, 10 May 2020 - 12:56 PM.


#3 clarkster72

clarkster72

    L Plates

  • Members
  • Pip
  • 4 posts
  • LocationHartlepool

Posted 10 May 2020 - 03:31 PM

Thanks for the reply. I'll try that fix even though doubt it is my issue as don't have any other issues apart from the park assist not working. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users