Jump to content

Follow us on...
Follow us on Google PlusFollow us on TwitterFollow us on Facebook
The UK's No.1 Chrysler Owners Forum

Photo
- - - - -

Seat-Belt Light?


  • Please log in to reply
8 replies to this topic

#1 Nello

Nello

    Advanced Driver

  • Members
  • PipPipPip
  • 399 posts
  • LocationCoventry

Posted 10 January 2017 - 03:24 AM

New Year - new slight issue noted................ I've spotted (not that it really bothers me TBH!) that my drivers light seat belt warning light - and as such the then annoying beep before you've clunk-clicked has stopped coming on ignition? When theres a passenger in the front seat the light works but not when theres just a drivers backside solo in the car? In classic Italian style its come on as normal a couple of times but most of the times its not coming on now......... I presume it'll be a seat sensor under the seat somewhere? Anyone else had this?


Edited by Nello, 10 January 2017 - 03:24 AM.


#2 MikeyRules

MikeyRules

    Advanced Driver

  • Members
  • PipPipPip
  • 437 posts
  • LocationCheshire

Posted 10 January 2017 - 09:19 AM

No not had that problem - Like you say it's probably a sensor under the seat. Might be worth checking it's not just a loose connection or plug that's not quite seated right.



#3 Nello

Nello

    Advanced Driver

  • Members
  • PipPipPip
  • 399 posts
  • LocationCoventry

Posted 10 January 2017 - 08:42 PM

Hmm - When I changed my headlight bulb I had to disconnect the Stop/Start lead off the battery which my car has as standard.

Doing this effectively disconnects the whole battery...........

Looking at the handbook on page 13 it mentions the Seat belt Reminder system and that it can only be switched off by the main dealer (presumably by the scan software)........

However it does state it can re-enabled by the Set-up menu (where you change the clock etc.) Its listed as an option to change in that menu in the book however its not showing when I scroll though on my car? I guess I'm going to have to get my mate to hook it up to the system when its next in for its MoT. I know not all options discussed in these user manuals are always available for all markets..........



#4 MikeyRules

MikeyRules

    Advanced Driver

  • Members
  • PipPipPip
  • 437 posts
  • LocationCheshire

Posted 11 January 2017 - 07:41 PM

I wonder if it's just had a hiccup with you disconnecting the terminal while you worked on it? Might be worth disconnecting it again for 10 mins to if you can reset it that way?



#5 Nello

Nello

    Advanced Driver

  • Members
  • PipPipPip
  • 399 posts
  • LocationCoventry

Posted 11 January 2017 - 09:10 PM

Might be right matey - seems to be working ok again now............. Guessing the ECU takes its time to rescan CANBUS connected systems?



#6 Rossocorsa

Rossocorsa

    Advanced Driver

  • Members
  • PipPipPip
  • 370 posts

Posted 12 January 2017 - 05:54 PM

The seat belt buzzer can be disabled or enabled in the small menu in the instument cluster but the option is only available for a few minutes after start up after then it defaults to headlight setting and so on. Quirky!

#7 Nello

Nello

    Advanced Driver

  • Members
  • PipPipPip
  • 399 posts
  • LocationCoventry

Posted 14 January 2017 - 10:59 AM

Thanks Alan - Will check that - wondered why I couldn't find the option.................



#8 MikeyRules

MikeyRules

    Advanced Driver

  • Members
  • PipPipPip
  • 437 posts
  • LocationCheshire

Posted 15 January 2017 - 11:32 AM

This is why forums are great - collective knowledge shared and we can diagnose anything! :P


  • Nello likes this

#9 Nello

Nello

    Advanced Driver

  • Members
  • PipPipPip
  • 399 posts
  • LocationCoventry

Posted 15 January 2017 - 02:12 PM

Yes - you cannot beat real-life owner experiences with cars.............  B)


  • MikeyRules likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users