Jump to content

Follow us on...
Follow us on Google PlusFollow us on TwitterFollow us on Facebook
The UK's No.1 Chrysler Owners Forum

News Feed

See the latest activity around the community, or follow your friends!


  • QinteQ%s's Photo
    QinteQ has posted in Which Engine Oil Do I Need ? in Voyager 4th Generation (2001-2007).
    It's your choice I use 5/30 full synth. Chrysler manual says 5/40 but even here in top north east we hardly ever get -10C. Cheepo to full synthetic is a price decision. Filters change equally criti...
  • bignev%s's Photo
    bignev has posted in Brake Warning Light Illuminating Intermittently in Voyager 4th Generation (2001-2007).
    I know you say the fluid level is spot on, but is it at the top?   The warning light is also for low fluid, so if it's intermittent it may be moving fluid, just my thought but if it isn't al...
  • QinteQ%s's Photo
    QinteQ has posted in Gearbox And Engine Revs in Voyager 4th Generation (2001-2007).
    Agree, I clearly remember I was more interested in the 'bench' seat at the time.[wistful smile at my age]. Sorry about the gobbledygook. Cursor over, left click, right click, download to, your pu...
  • oldginger%s's Photo
    oldginger has posted in Gearbox And Engine Revs in Voyager 4th Generation (2001-2007).
    Thanks for the help QinteQ. I will get my wife or grandson to help me with this because once you go to downloads and the rest your talking gobbledygook. I will add though, that I can happily take t...
  • BrownSugar%s's Photo
    BrownSugar has posted in Abs/esp Lights On After Dead Battery Swap in Chrysler 300c.
    No mate. I never go to Chrysler. My garage has more than one type of code reader available to them. Also, code readers need regular software updates. It's a blind science this stuff, like I said be...
  • Sentech%s's Photo
    Sentech has posted in Brake Warning Light Illuminating Intermittently in Voyager 4th Generation (2001-2007).
    Thanks for the inputs.   The fluid level is spot on,and the vehicle sailed thru its inspection less than a month ago.   I'll check out the other adjustments recommended this weekend a...
  • QinteQ%s's Photo
    QinteQ has posted in Gearbox And Engine Revs in Voyager 4th Generation (2001-2007).
    The download are actually 5 separate 2005 year pdf's (portable document format) covering all areas particularly the UK/EU platform diesels. This document is easily read by most computers and all wi...
  • oldginger%s's Photo
    oldginger has posted in Gearbox And Engine Revs in Voyager 4th Generation (2001-2007).
    Thanks for the info much appreciated. The oil appeared to be in good condition but showing low on the dipstick when hot and normal when cold so went for measured top up 300 MILLILITRES. As mentione...
  • QinteQ%s's Photo
    QinteQ has posted in Gearbox And Engine Revs in Voyager 4th Generation (2001-2007).
    DUP
  • QinteQ%s's Photo
    QinteQ has posted in Gearbox And Engine Revs in Voyager 4th Generation (2001-2007).
    The Chrysler issue workshop manuals I answered in #5 of your other thread. In N or P car will not / should not rev above 2.5k RPM my friend. Gearbox logic will de-tune or in this case re-learn your...
  • gadge%s's Photo
    gadge has posted in Abs/esp Lights On After Dead Battery Swap in Chrysler 300c.
    @BrownSugar  would it have to be from a chrysler garage to get a compatable code reader.   Gadge.
  • BrownSugar%s's Photo
    BrownSugar has posted in Abs/esp Lights On After Dead Battery Swap in Chrysler 300c.
    It's a nightmare, it took me less than a minute to disconnect and remove the old battery and then connect up the new one.   Next time I change the battery I'm gonna get a second one, wire it...
  • gadge%s's Photo
    gadge has posted in Abs/esp Lights On After Dead Battery Swap in Chrysler 300c.
    I have an 07 300c, took old Bty out and put new Bty in, the following day, the wipers,indicators,front windows,mirrors do not work also on dash ABS, ESP, BAS, all stay lit with the engine running e...
  • CRD28AUTO%s's Photo
    CRD28AUTO has posted in Abs/esp Lights On After Dead Battery Swap in Chrysler 300c.
    Don’t know if this helps, but my Grand Voyager does this every time I swap the battery. Well it’s just the abs light. But after about a week of use, it turns off itself.  Then I have no more...
  • BrownSugar%s's Photo
    BrownSugar has posted in Abs/esp Lights On After Dead Battery Swap in Chrysler 300c.
    I had exactly the same problem. I replaced the battery then the ESP, ABS, and engine light came on. Took the car to my mechanic, he plugged in his code reader and successfully cleared all the fault...
  • QinteQ%s's Photo
    QinteQ has posted in Brake Warning Light Illuminating Intermittently in Voyager 4th Generation (2001-2007).
    Sentech Your car started. Wheels facing forward. STAND on footbreak. 6 good Yuk's on Hand Brick. Will equalise Y cable and clockspring. Light out ? If not you may have bad wheel sensor reading. Be...
  • bignev%s's Photo
    bignev has posted in Brake Warning Light Illuminating Intermittently in Voyager 4th Generation (2001-2007).
    Have you been under the bonnet and checked the brake fluid level?
  • QinteQ%s's Photo
    QinteQ has posted in What Is This Sensor For ? in Voyager 4th Generation (2001-2007).
    Location is ditto with old.   Outside temp so RAD and other heat source should be avoided my friend.
  • Nello%s's Photo
    Nello has posted in Front And Rear Discs in Chrysler Delta.
    Guessing that these Vids on Brake changes on a Bravo are the same for our cars - useful -    https://www.youtube.com/watch?v=mqquAW9WuQY&t=333s
  • frogland%s's Photo
    frogland has posted in What Is This Sensor For ? in Voyager 4th Generation (2001-2007).
    Thanks QuintQ for the quick reply ! Whereabouts should it be fixed ? On the bumper ? Thanks again.
  • QinteQ%s's Photo
    QinteQ has posted in Brake Warning Light Illuminating Intermittently in Voyager 4th Generation (2001-2007).
    Adjust. Leedsmans thread with photo's here: https://www.chryslerforum.com/forum/chrysler-voyager-town-country-21/my-struggles-gv-handbrake-mot-22210/
  • QinteQ%s's Photo
    QinteQ has posted in What Is This Sensor For ? in Voyager 4th Generation (2001-2007).
    Ambient Temperature Sensor.
  • fryingscot%s's Photo
    fryingscot has posted in Chrysler Pt Cruiser 2005 2.4 Ltd - £160 Whole Car - Accident Damaged Rear Quarter in Classifieds.
    Vehicle now sold
  • gordy%s's Photo
    gordy has posted in Leak In Heating Pipe Under The Car in Voyager 4th Generation (2001-2007).
    Was just going to add with these adverts on our screens nowadays, there are some remarkable coloured plastic tapes for sale. You have probably viewed the latest one where the dude pulls the tape of...
  • horvatlo%s's Photo
    horvatlo has posted in Leak In Heating Pipe Under The Car in Voyager 4th Generation (2001-2007).
    hi all,   i have got the same problem with my 2.5 RG IV . i cant found the part number and i dont found on ebay.   is there possible to get a new intake pipe assembly?   Thank...
  • bignev%s's Photo
    bignev has posted in Gearbox Inquirery in Voyager 4th Generation (2001-2007).
    Slip doesn't sound good, maybe some new fluid to drop out some of the dirty contaminated crud that might be getting in the way of the friction plates will help. A change of fluid certainly shouldn'...
  • QinteQ%s's Photo
    QinteQ has posted in Gearbox Inquirery in Voyager 4th Generation (2001-2007).
    I only ever use Chrysler recommend oil which is ATF+4. It doesn't have to be their Mopar brand but I'd never put anything else in my friend. Ditto recommend engine/coolant/brake fluid even. The tr...
  • oldginger%s's Photo
    oldginger has posted in New Member & Battery Experience in Voyager 4th Generation (2001-2007).
    Hi, only just picked up this topic. I read lots of topics during my research into replacing the battery that came with my GV. Where I live is a very well known battery supplier and everyone I consu...
  • Andrewgrale%s's Photo
    Andrewgrale has posted in Front And Rear Discs in Chrysler Delta.
    As Euro Car Parts have a sale on again - what front pads are people recommending - they have Eicher / Pagid or Brembo? I got Brembo, front and rear, work well, no screeching and no fade in har...
  • TJB%s's Photo
    TJB has posted in Front And Rear Discs in Chrysler Delta.
    As Euro Car Parts have a sale on again - what front pads are people recommending - they have Eicher / Pagid or Brembo? I ended up with DriveTec discs and pads from my local parts factor. T...
  • Nello%s's Photo
    Nello has posted in Front And Rear Discs in Chrysler Delta.
    As Euro Car Parts have a sale on again - what front pads are people recommending - they have Eicher / Pagid or Brembo?
  • QinteQ%s's Photo
    QinteQ has posted in Leak In Pipe To Auxiliary Heater in Voyager 4th Generation (2001-2007).
    Thanks for the graphics, they always speak a thousand words. Fracture in a chamber, that's a proper sod, hope you can effect a repair. Webasto's are major boost for a great big 3 litre cold lump of...
  • gordy%s's Photo
    gordy has posted in Leak In Pipe To Auxiliary Heater in Voyager 4th Generation (2001-2007).
    Here's the inside spagetti if interested. There is a printed circuit board in there as well. In the case of mine the heat transfer chamber was fractured, that's the ribbed chamber.
  • QinteQ%s's Photo
    QinteQ has posted in Leak In Pipe To Auxiliary Heater in Voyager 4th Generation (2001-2007).
    I've never heard mine though I do hear it when it switches off. The burn bowl on the 'WaterTop' should expell it's burnt/unburned fuel into the mini-exhaust system. Certainly they contain [disposab...
  • VOYAGER1%s's Photo
    VOYAGER1 has posted in Leak In Pipe To Auxiliary Heater in Voyager 4th Generation (2001-2007).
    Here's a picture of the heater thats below and the hoses. So is leak from heater or pipes that go up to engine. If heater its Goosed.  I have the same heater. Since it is too noisy li...
  • VOYAGER1%s's Photo
    VOYAGER1 has posted in Humming Noise From 2.8L Crd Engine in Voyager 4th Generation (2001-2007).
    Noise cannot be heard at idle even while driving. So, neither wheel bearings nor alternator bearings could be the problem. 
  • RichardM%s's Photo
    RichardM has posted in Information Center Lamps in Voyager 4th Generation (2001-2007).
    From the manual (basically as above but the Yanks are quite verbose ; MESSAGE CENTER REMOVAL (1) Disconnect and isolate the battery negative cable. (2) Using a trim stick (special tool #C-4755)...
  • 03GVCRD%s's Photo
    03GVCRD has posted in Information Center Lamps in Voyager 4th Generation (2001-2007).
    Yes, it's very simple. The upper cluster is a unit in itself and fitted with clips. You just need to gently prise it out. There is one multiplug to take out and the bulbs are a simple twist fit.
  • gordy%s's Photo
    gordy has posted in Humming Noise From 2.8L Crd Engine in Voyager 4th Generation (2001-2007).
    Was going to say it's the the bearings in the alternator, as it hums when they go dry. But you say the humming comes and goes..Well possible idea.
  • Eightpint%s's Photo
    Eightpint has posted in Heater Controls Gone Haywire in Chrysler 300c.
    I thought my soldering was neat, but somewhere on that board I messed up, so off to scrappy to buy another, I will let u know how it goes.
  • BrownSugar%s's Photo
    BrownSugar has posted in Heater Controls Gone Haywire in Chrysler 300c.
    Sadly I think that's the case.   Don't want to teach you to suck eggs, but earth yourself before touching the board. Also, how big is your soldering iron? I also had to replace those lights...
  • QinteQ%s's Photo
    QinteQ has posted in Ilink 400 Diagnostic Scanner in Voyager 4th Generation (2001-2007).
    See here : https://www.babybmw.net/viewtopic.php?t=81439&start=15 I bought one of these BA5 battery testers about 10 years ago. It correctly reported the F21 as an AGM but of course the GV can NOT...
  • QinteQ%s's Photo
    QinteQ has posted in Ilink 400 Diagnostic Scanner in Voyager 4th Generation (2001-2007).
    GV's do not like AGM batteries and the Optima is AGM. If memory serves me Chrysler invented 'on alternator logic' as long as the 80's and still use similar set ups of pulse-width modulated (PWM) vo...
  • TJB%s's Photo
    TJB has posted in Springs in Chrysler Delta.
    That's a big help. I have the KYB RH3908 on mine, I still think it looks too high at the front, but as it's a working car, I needed it sorted asap. I may look at changing them, depending on what el...
  • RichardM%s's Photo
    RichardM has posted in Ilink 400 Diagnostic Scanner in Voyager 4th Generation (2001-2007).
    Thanks for the replies guys. The function list covers the GV inc 2007 (what the functions mean is double Dutch or Chinese to me...but it's good to know (1) it's a reputable piece of kit and (2) it...
  • CRD28AUTO%s's Photo
    CRD28AUTO has posted in Ilink 400 Diagnostic Scanner in Voyager 4th Generation (2001-2007).
    Here is a link to the function list for each module. https://drive.google.com/drive/folders/1sKAET0ezinyZgamPIDiYCBk1zYIIzzWy?usp=sharing   Hope this helps.
  • CRD28AUTO%s's Photo
    CRD28AUTO has posted in Ilink 400 Diagnostic Scanner in Voyager 4th Generation (2001-2007).
    I actually own a ILink400 but have not yet brought the Chrysler module. I have the VAG and Vauxhall modules on it. It is a excellent diagnostic tool for the money and allows you to perform most dea...
  • Eightpint%s's Photo
    Eightpint has posted in Heater Controls Gone Haywire in Chrysler 300c.
    Hi, My original heater panel worked as it should but had failed lights, so I brought a replacement set of bulbs and attempted my first soldering session, thought I did ok but when fitted it I lost...
  • BrownSugar%s's Photo
    BrownSugar has posted in Headlamps Flicking in Chrysler 300c.
    Yes mate. Change the headlight switch. It's a common cause for flickering headlights. Go to www.1aauto.com for quality video on how to replace the switch. You'll find switches on ebay, but there's...
  • BrownSugar%s's Photo
    BrownSugar has posted in 300C Diesel in Chrysler 300c.
    I was thinking... I had a similar problem years ago on a motor with a petrol engine. It turned out to be the airflow sensor.